
Creating Accessible Documents 
When creating content, there are a few basic steps that should be followed in order to assure your 

content is accessible.  It is recommended that documents are started in Microsoft Word and then 

appropriately exported into PDF.  A checklist is provided, with detailed instructions for each step 
outlined below. 

To see why creating accessible documents is important, check out this 3 minute video of a screen reader 

going through accessible and inaccessible Word Documents: 

https://www.youtube.com/watch?v=D8XFkGMF0sw.  And here is an example of a screen reader going 
through an inaccessible PDF: https://www.youtube.com/watch?v=GaNwnsT4B5s. 

Checklist when starting in Word 

o Added built-in Headings to document and did not skip numbers (e.g. jumping from Heading 1 to 

Heading 3) 

o Used built-in List options (e.g. bullets or numbers) 

o Added Alt Text for all images 

o Identified the document language 

o Defined Table Headers and simplified Tables as much as possible  

o Avoided floating objects 

o Used descriptive text for hyperlinks 

o (optional) Exported to PDF while preserving accessibility 

 

Use headings 
Use the built-in Heading styles like “Heading 1″ and “Heading 2″, available under Styles in the Home tab 

of the Ribbon in Office versions 2010 and higher.  Making text larger and bold does not make it a 

heading.  Try not to skip headings.  After a heading has been selected, you are able to e dit the font, size 
and other attributes if you do not like the built-in look. 

https://www.youtube.com/watch?v=D8XFkGMF0sw
https://www.youtube.com/watch?v=GaNwnsT4B5s


 

 

Use lists 

Use the built-in options like bullets or numbers, available under the Paragraph in the Home tab of the 

Ribbon in Office versions 2010 and higher.  Without using these, a list is not really a list to those using an 

outside program to read the document.  Both numbered and bulleted lists are customizable. Just click 

on the arrow adjacent to the desired list button and select “Define New Bullet/Number Format” for a 
different design if you do not like the built-in options. 

 

 

 

Add alternate text for Images 
In most versions of Word, you can enter alternate text by right clicking an image and selecting Format 

Picture. Within the Format Picture dialog, select Layout and Properties, then select Alt Text.  To enter alt 

text in Office 2007, right click an image and select Size and Positioning. Then select Alt Text.  It’s 

http://www.washington.edu/accessibility/files/2013/09/Word_Headings.png
http://www.washington.edu/accessibility/files/2013/09/Word-lists.png


recommended to provide the description of the picture in the ‘Description’ field; you should only enter a 
‘Title’ if your ‘Description’ field text is long and detailed. 

 

 

Identify document language 
In Office 2010 for PCs, within the Review tab, select the Language button, then select “Set Proofing 

Language”. 

 

In Office 2011 for Macs, select Tools > Language from the application menu to define the default 

language. To define a different language for part of the document, select each foreign language 

individually, then select Tools > Language to define the language for each. 

 

http://www.washington.edu/accessibility/files/2013/09/Word2010-lang.png
http://www.washington.edu/accessibility/files/2013/09/Word-lang.png


NOTE: Currently language settings only effect accessibility of the Word document itself. They 

do not survive when exported to PDF. If PDF is the final format in which you intend to distribute your 

document, you will need to define language in the PDF directly using Adobe Acrobat Pro. 

 

Use tables wisely 
Word has limitations when it comes to making tables accessible. Tables can be very difficult for screen 

reader users to understand unless they include markup that explicitly defines the relationships between 

all the parts (e.g., headers and data cells). For a simple table with one row of column headers and no 

nested rows or columns, Word is up to the task. However, more complex tables can only be made 

accessible within HTML or Adobe PDF (accessible table markup can be added to the PDF using Adobe 
Acrobat Pro). 

Often complex tables can be simplified by breaking them into multiple simple tables with a heading 
above each. 

For simple tables, the only step necessary for accessibi lity is to identify which row contains the column 

headers. To do this in Word, select that row (Table > Select > Row), then right click the row and select 

“Table Properties”. This brings up the Table Properties dialog. In this dialog, click the Row tab, and check 
the checkbox that says “Repeat as header row at the top of each page”. 

 

 

Avoid floating objects 

Objects that are not in line with text are challenging to navigate, and they may be inaccessible to users 

with vision impairment. Setting text-wrapping around objects to Top and Bottom or In Line With Text 
makes it easier for people with screen readers to follow the structure of your document.  

To change the text-wrapping around objects, do the following: 

http://www.washington.edu/accessibility/files/2013/09/Word-tables1.png


1 Select the object, and right-click. 

2 Choose Wrap Text, and then select either In Line With Text or Top and Bottom from the list. 

 

Use descriptive text for hyperlinks 
When including hyperlinks in a Word document, it is important to include a description of the 

destination, so that readers can choose whether or not to click the link.  

To create or edit a hyperlink, select the text you would like to convert into hypertext, and then right-

click on the selection. In the submenu, select Create hyperlink... or Edit hyperlink... In the Edit Hyperlink 
dialog box, enter some descriptive text in the Text to display field. 

 

 



When exporting to PDF, understand how to preserve accessibility  

There are right ways and wrong ways to export to PDF.  The steps required depends on which version of 

Microsoft Word you’re using.  Do not print to PDF. This method of creating a PDF does not preserve the 

document’s accessibility features. The correct method of exporting to PDF depends on which version of 

Microsoft Office you’re using. 

Word 2013 and Word 2010 (Windows) 

Go to File > “Save As…” and select PDF from the choices provided. By default this produces a PDF that 
preserves the document’s accessibility features. 

When saving, select Options and be sure that “Document structure tags for accessibility” is checked. This 
is checked by default, but could become unchecked under certain ci rcumstances. 

If you select “Minimize Size” to reduce the size of your PDF, be sure to repeat the preceding step, as this 

option might uncheck the “Document structure tags for accessibility” checkbox.  

Word 2007 and Word 2003 (Windows) 

Prior to Office 2010, exporting to an accessible PDF requires a plug-in. The Adobe PDF Maker Plugin 

ships with Adobe Acrobat Pro, and the plugin is installed into Office and appears as an Adobe toolbar 

and menu item. With this plug-in installed, use the Adobe toolbar or the Adobe menu item to Save As 
PDF.  By default this produces a PDF that preserves the document’s accessibility features.  

Word for Mac 

As of Word 2011, it is unfortunately not yet possible to export to accessible PDF from a Mac. You can 

create an accessible Word document in Word 2011, but if you ultimately need to export the document 

to PDF that final step must be taken in Windows. 

 

  



Checklist when using an existing PDF 

The checklist specifically applies to Acrobat Pro X and XI. Many of the same principles applied in earlier 

versions of Acrobat as well, but the steps for completing them are different. For additional information 

about fixing accessibility using Acrobat Pro versions 7 through 9, see WebAIM’s tutorial PDF go here: 

http://webaim.org/techniques/acrobat/acrobat7to9.  NOTE: Modifying PDFs can have unpredictable 
results, and there is no undo.  Save often! 

o Tested for image or text file; converted to text if needed 

o Tested for tags; added tags if needed 

o Tested for Reading Order; hid unnecessary images, added alt text, rearranged reader order, edited 

tables if needed 

o Tested for Headings; added built-in headings if needed 

o Tested for markup; tagged lists, tagged tables, put content in reasonable order if needed 

o Tested for URLs as links; created links if needed 

o Tested for Language; identified if needed 

o Tested for Other Errors, fixed if needed 

 

Step 1. Does document have text? 
How to test: Try selecting text using a mouse, or select all text using Edit > “Select All” from the Acrobat 

menu. 

If No: This is an image file and is not accessible. Covert to text using View > Tools > “Recognize Text”.  

 

  

http://webaim.org/techniques/acrobat/acrobat7to9


Step 2. Is document tagged? 

How to test: Go to File Properties (Ctrl+D in Windows, Command+D in Mac). In the bottom left corner of 
the Document Properties dialog, see the “Tagged PDF” field. 

If No: this document needs to be tagged. Tags provide the structure on which accessibility is built. Add 
tags by selecting View > Tools > Accessibility > “Add Tags To Document”. 

 

 

Step 3. Does document need to be “touched up”? 

How to test: Use View > Tools > Accessibility > “Touch Up Reading Order” to see the order in which 

content on the current page will reflow if the document is viewed in a small window such as on a  mobile 

device. This can also provide a fairly (though not entirely) accurate representation of the order in which 
screen readers will read the content. 

Some accessibility fixes can be made using this tool. Here are a few: 

 Hide decorative or redundant images from screen reader users. To do so, click an image, then click 

“background” 

 Add or edit alt text for informative images. To do so, right click on an image, then select “Edit alt 

text”. 

 Rearrange read order if needed. To do so, click “Show order pane l”, then drag items to their 

appropriate location. 

 If the page includes data tables, click a table, then click the “Table Editor” button to edit accessibility 

features within the table. 

 

http://www.washington.edu/accessibility/files/2014/01/Adobe-Document-Properties1.png


Step 4. Are headings marked up as headings at appropriate levels? 

How to test:  First, study the document visually to determine what the heading structure should be.  

Next, open the Tags Panel by selecting View > Show/Hide > “Navigation Panes” > Tags. The Tags Panel 
shows a tree of tags that is very similar to HTML. 

 

There are a variety of ways to explore the tag tree. For example, use Acrobat’s text selector tool to 

highlight text in the document (for example, a heading) then click the menu icon at the top of the Tags 

pane and choose “Find tag from selection”. This will expand the tag tree if needed and highlight the 
selected tag. 

Alternatively, click the menu icon at the top of the Tags pane and be sure “Highlight Content” is 
checked. Then click on any tag to see the content associated with that tag highlighted in the document. 

Headings should be marked up with tags that are equivalent to HTML headings tags (i.e., <H1> for the 

main heading, <H2> for subheadings, then <H3>, <H4>, etc. Some authoring tools may create tags that 

have heading-like names (e.g., “<Heading_Level_1>”). However, these are not recognized by screen 
readers and will need to be changed. 

To change a tag, right click on the tag, select Properties, then choose an appropriate tag from the list. If 

you know what the correct name should be for a particular tag, you can also double-click the tag and 

type in the correct name. 

 

Step 5. Does other markup need to be fixed? 

How to test: Follow the same instructions as in the previous step. However, rather than focusing 
specifically on headings, consider the overall structure. 

Are lists tagged as lists? 

http://www.washington.edu/accessibility/files/2014/01/Adobe-Tags-Panel.png


Does content in appear in a reasonable order?  In Step 3 you checked the read order of content, and 

may have rearranged some items so they would flow in a meaningful order in a small window. While this 

order is typically close to the order of items in the tag tree, the latter is the actual order in which items 

will be read by screen readers. If items seem to be out of order in the tag tree, drag them to a better 
location. 

Authoring tools generate a wide variety of tags. These typically aren’t cause for alarm, as screen readers 

ignore most of them and render their content as paragraphs. As long as headings are tagged as 

headings; and lists, tables, and images are all tagged up appropriately, a document will likely be easy  for 
screen reader users to navigate, read, and understand. 

In some cases, the tag tree of a document is a total mess, and it might be easier to delete all tags and 

start over building them from scratch rather than try to fix the existing tags.  

 

Step 6. Are URLs encoded as links? 
How to test: Try clicking a link to see if it attempts to open the target resource in a web browser.  

If not: go to Tools > “Document Processing” > “Create Links from URLs” 

Step 7. Is the language of the document defined? 
How to test:  Go to File > Properties > Advanced > Language. 

If not: If no language is specified, select one and save the document. 

Step 8 Check for any lingering errors 
How to test: Run the accessibility checker that is built in to Acrobat Pro.  Select Tools > Accessibility > 
“Full Check” then read the report and follow the prompts. 

This is the final step in our checklist, rather than the first step, because some documents generate 

dozens of errors that can easily be addressed with the first seven steps. This way, the accessibility 
checker will report fewer problems and will be easier to read and work with.  
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